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1  Introduction 
MMPlayer is a media player capable of playing many types of files on your 
PalmOS handheld. Supported formats include, but are not limited to, MP3, OGG, 
MIDI, MP2, WAV, AVI, MPG, MOV, 3GP and MKV. MMPlayer offers many unique 
features.  One key feature is MMPlayer’s ability to play standard file types such as 
avi and mpeg. This feature lets you play the same media file on your PC that you 
play on your PalmOS device (assuming your PalmOS device is powerful enough). 
In addition, the MMPlayer’s standards based media file size is usually a lot smaller 
than the proprietary encoded formats used by other media players. This means 
you can save a media file with a lot less memory and still play it using the 
MMPlayer media player. In short, the MMPlayer media player gives you the ability 
to use the same file on your PalmOS device and your PC and it also lets you use a 
lot less memory than some of the other PalmOS based media players. 
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2 Installation 
The MMPlayer media player is installed like any other Palm program. Just unpack 
the zip-file and double-click on the files that should be installed. These files will be 
transferred to your Palm at the next Hotsync. 

If you want to save memory space in your device, you can install MMPlayer on a 
memory card or hard drive. 

If you want a nicer look than the built-in default skin, you can install additional skins 
from the Skins directory of the MMPlayer zip file. If you want MMPlayer to look like 
the pictures in the manual, you should install the Gray skin. 

2.1 Required files 

The following files must always be installed: 

• MMPlayerGUI.prc 

• MMPlayerLib.prc 

2.2 Optional files 

For certain features described below, additional files are needed. Also please read 
chapter 3 for more information about files that need to be installed on your 
particular type of device. 

2.2.1 MIDI 

If you want to play MIDI files (with the extension .mid), you must also install the file 
MMMidiInstr.pdb. 

2.2.2 Skins 

If you want MMPlayer to look more fancy than the built-in skin does, you can install 
one or more of the skins in the Skins directory. Please see chapter 13 Skins for 
more info. 

2.3 Upgrading from a previous version 

When upgrading MMPlayer from an older version, the best solution is to install the 
new version over the old version without first removing the old. If you remove the 
old version, all settings will also be removed and you need to change the settings 
to desired values. 
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3 Quick start 
Here's a guide for the impatient who quickly wants to start playing media with 
MMPlayer. (This guide assumes you’re using the built-in default skin. If you have 
selected another skin, some of the steps will be a bit inaccurate but will still be 
possible to perform using the corresponding button on the skin you’re using). 

1. Install MMPlayer 

2. Copy your media file(s) to your Palm's memory card using the standard 
install application by dropping the media file onto the install application’s 
window. Note that some conduits, such as the Media conduit from PalmOne 
and Kinoma Producer, may convert movie files to their format. This 
conversion must be prohibited by disabling such conduits, otherwise 
MMPlayer will not be able to either find nor play the files. See the trouble-
shooting guide for more info about unwanted conversions. Also note that 
Step 2 and 3 can be replaced by using a card reader and simply drop the 
files in the directory on the card where you want to install the files. 

3. Hotsync. This will transfer the media file to the memory card. The tricky part 
is to know in which directory the file will end up. In Palm OS, it's possible to 
map file extensions to default directories on memory cards, so depending on 
this mapping, different file types will be copied into different directories. An 
educated guess is that music files will be copied into /AUDIO and video files 
into /DCIM, but this may not be the case for your particular setup, so you 
might have to browse around a while to find the file. 

4. Start MMPlayer. 

5. Tap the Playlist tab. 

6. Press the 'Add' button. 

7. In the file selection dialog, browse to the directory where the file was 
installed; select the file and press 'Ok'. (If you can’t browse to another 
directory or if you can’t find the files you have installed, see chapter 21 
Troubleshooting guide.) 

8. Select the file in the playlist. 

9. Tap the 'Main' tab. 

10. Press the 'Play' button. 

Now, the file should start playing. If it doesn't, please check that the format and 
codecs of the files are included in the list of currently supported formats and 
codecs. 

If the file is audio only, you should see a few lines of data about the file. But if the 
file contains video, the video should be displayed in the video area. To expand the 
video into the whole available screen, just tap the video area. 
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4 Compatibility 
Since media decoding is a complicated process, it requires a powerful processor 
such as the ARM processors found in Palm OS 5 devices. MMPlayer will not run 
on older devices. As of this writing, MMPlayer have been successfully tested on: 

• Palm Tungsten | T 

• Palm Tungsten | T2 

• Palm Tungsten | T3 

• Palm Tungsten | T5 

• Palm Tungsten | TX 

• Palm Tungsten | C 

• Palm Tungsten | E 

• Palm Tungsten | E2 

• Palm Zire 31 

• Palm Zire 71 

• Palm Zire 72 

• Palm Treo 600 

• Palm Treo 650 

• Palm Treo 700p 

• Palm Lifedrive 

• Garmin iQue 3600 

• Sony UX 40/50 

• Sony Clie TG/NX/NZ 

• Tapwave Zodiac 1,2 

This list will grow in the future. If your device is not listed, there’s probably a good 
chance MMPlayer will run on it anyway. Very few devices have required special 
changes in the course of MMPlayer development. 

4.1 Device specific setup 

MMPlayer requires some additional steps for certain devices. Review the section 
for special instructions for your device. 

4.1.1 Palm Tungsten | T3 

Install the additional files in the TungstenT3 support directory. These files are 
official patch files from PalmOne enabling third party software like MMPlayer to 
use the virtual graffiti area. These files may already be installed, but there is no 
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harm in doing it again. (Note that these files have been removed from the 
MMPlayer distribution since too many people installed them on other devices 
causing pretty bad side effects. Please email support@mmplayer.com if you need 
them.) 

4.1.2 Handspring Treo 600 and Zire 31 

Since these devices have a smaller screen resolution than most other Palm OS 5 
devices, it requires that the skin used is adapted for that resolution (160x160). At 
this time, only the Plain, Black and the default skins are adapted to that resolution. 

4.1.3 Sony Clie (TG/NX/NZ) 

These devices use a non-standard audio API. To use MMPlayer on these, please 
use the 3rd party program called MCA2 to enable Hi-Fi audio on these Clie models. 
See http://www.aibohack.com/clie/modclieaud.htm to download MCA2. Note that 
the MCA2 web page states that MMPlayer should be set to “off” in the MCA 
settings, but the MCA setting must be set to “on”. 

http://www.aibohack.com/clie/modclieaud.htm
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5 Playable media types 
MMPlayer is very powerful and supports many types of media.  It can play both 
music and video; it can play a variety of formats e.g. avi; and it can play files 
encoded in many standard codecs.  However, it is not always obvious what can 
and cannot be played. This chapter covers formats, codecs, and protocols in an 
attempt to explain this in greater detail so you can get the most out of your 
PalmOS device. 

5.1 Formats, Codecs, and Protocols 

Three things determine if a media file can be played by a media player.  Support 
for the format, support for the codec, and support for the protocols.   

5.2 File formats 

A common misunderstanding about file formats is to think that once a player 
supports a particular file format, any file using that format can be played. This is 
not true. 

File formats are like chapter headings.  Once the media player knows the file 
format, which can often be done by looking at the extension (e.g. mp3 or avi), it 
can then attempt to read the contents of the information within the paragraphs of 
the file. 

Considering a couple of example may help.  As a first example consider an mp3-
file. An mp3-file can only contain one audio stream.  Knowing this the reader can 
expect that it will be required to play an audio file.  However, this still does not tell 
the reader how the audio is written.  As a second example consider an avi-file.  An 
avi-file can contain one audio stream and one video stream.  Knowing this format 
is not sufficient for a media player to know how to play the contents contained in 
the audio or video stream. 

In summary, being able to read a file format is like being able to discern the 
chapter layout of a book.  The reader can see where each chapter starts and ends, 
but if the language of the chapters is unknown to him, he can’t read the book 
anyway; so he needs to be able the read the language also.  File formats assist a 
media player to read a file; however, by itself it’s not enough to insure that the 
media player will be able to read the file contents. 

5.3 Codecs 

Here’s where the codec comes into play. The codec is the language with which the 
audio and video packets are written. The word “codec” is short for coder-decoder. 
Codecs are used to both encode media into a stream of ones and zeroes, and 
decode that stream back to the original media. There is an advantage of coding 
content using codecs instead of file formats. A file format can contain a mix of 
codecs.  For example, you can use the DivX codec for the video stream and the 
mp3 codec for the audio stream. Both streams are kept in an avi-file format; hence, 
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the file that contains these two streams would have a “.avi” extension.  If a better 
audio codec appears, you can simply re-encode the audio stream using the new 
audio codec and stick with the old video codec.  Once again the file format would 
remain as an avi media file format. 
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5.4 Protocols 

Lastly, the protocol defines how the content of the file is transferred from storage to 
MMPlayer.  For example, the 'ext' protocol reads files from a memory card , the 'int' 
protocol reads files from internal memory and the ‘http’ protocol reads files from 
the internet. 
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6 MMPlayer controls 
This chapter lists the various controls and settings of MMPlayer. Since MMPlayer 
is “skinnable,” it is impossible to describe exactly where each button and other 
controls are placed for all skins.  This chapter describes the skin called “Gray” and 
how to find the controls on that skin.  For example, the Gray skin uses two 
separate forms for the main and playlist controls whereas other skins shows the 
playlist (or preferences) as a extensions of the main form. As a new user, you 
should use the Gray or the built-in default skin. Once you become familiar with 
MMPlayer, you can select the skin you prefer.  

Note that the skin system in MMPlayer is very flexible and allows the skin designer 
to have any number of forms and put any number of buttons and controls on those 
forms. For the end user, this means that when searching for a button or control, 
you may have to look through all available forms before you find it, or you might 
find it on more than one form. 

6.1 The main form 

The Gray skin has two forms. The main form (below) has two different layouts 
depending on what type of media is being played. If audio is currently played, the 
MMPlayer looks like the left picture below.  If video is played, the MMPlayer looks 
like the right picture. 

Note: some controls (brightness and contrast) are only available when playing 
video because those controls are not in use when playing audio only. 

      

Main form: Audio layout     Main form: Video layout 
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6.1.1 Play button 

The play button starts playing the currently active file. 

6.1.2 Stop button 

The stop button stops the currently playing file. 

6.1.3 Back button 

The back button (left arrow) steps back one file in the playlist. However, if the 
currently playing file has bookmarks, it starts playing at the nearest bookmark 
before the current position. 

6.1.4 Next button 

The next button (right arrow) steps forward one file in the playlist. However, if the 
currently playing file has bookmarks, it starts playing at the nearest bookmark after 
the current position, or if there’s no more bookmarks after the current position it 
steps forward to the next file in the playlist. 

6.1.5 Volume slider 

The volume slider controls the volume of the audio. 

6.1.6 Pan slider 

The pan slider controls the left-right balance of the audio. 

6.1.7 Brightness slider 

The brightness slider controls the brightness of the video. This slider is only 
available when playing a video file. 

6.1.8 Contrast slider 

The contrast slider controls the contrast of the video. This slider is only available 
when playing a video file. 

6.1.9 Repeat button 

The repeat button controls whether the playlist should start over from the 
beginning again when the last file has been played. 

6.1.10 Shuffle button 

The shuffle button controls whether the files in the playlist should be played in 
random order or from start to end. 
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6.1.11 Position slider 

The position slider shows where in the currently playing file MMPlayer is playing at 
the moment. It’s also possible to grab the position slider and move it to a new 
position to seek within a file. 

6.1.12 Eq button 

The eq button controls whether the equalizer is active or not. Note that an audio 
equalizer is a fairly complex process and will consume a certain amount of CPU 
time. If performance is crucial, you may get a better viewing experience with the 
equalizer turned off. 

6.1.13 Eq band sliders 

Use the eq band sliders to adjust the 5 bands of the equalizer as needed. 

6.1.14 Amp slider 

The amp slider amplifies the audio. Some Palm devices have a bit weak audio 
output gain. This amplifier slider can be used to give such devices an additional 
volume boost. Note that the highest setting is very LOUD and you’ll probably never 
need to nudge it very much. In fact, it’s so powerful that the slider has a built-in 
safety catch, prohibiting a user from increasing it more than a little at a time. 

6.1.15 Fullscreen toggle 

There’s one last control that doesn’t have an ordinary button. The whole video 
area is also a fullscreen toggle, just tap it and MMPlayer will expand the currently 
playing video onto the whole screen. 

Some devices, notably those with a 480x320 screen, have a status bar with a 
button for collapsing the virtual graffiti area. When this button is used, MMPlayer 
will not go to fullscreen but will remain in window mode, although with a larger 
window. Some skins will use this larger window to make the video area larger or in 
other ways make better use of the increased space. 

6.2 The playlist form 

The playlist form is shown below and is used to add and remove files to the playlist. 
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6.2.1 Play button 

The play button does exactly the same thing as it does on the main form. 

6.2.2 Add button 

The add button opens a file selection dialog.  The add button lets you select one or 
more files for inclusion in the playlist. 

If you have a hard time reading the text in the file selection dialog, you should 
consider changing the font settings, see 12.4. In fact, if you select the halfsize font 
on a device with a 160x160 screen, you will only see unreadable dots. 

Note! If you used the standard Palm install tool to copy the file to a memory card, 
the file will probably be copied into the /DCIM directory. See 19.2 for more info. 

6.2.3 Remove button 

The remove button removes the currently selected file from the playlist. 

6.2.4 Move up button 

The move up button moves the currently selected file up one step in the playlist. 

6.2.5 Move down button 

The move down button moves the currently selected file down one step in the 
playlist. 
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6.3 Other features 

6.3.1 Resume 

Resume doesn’t have a button, but it’s nevertheless a useful function. If you exit 
MMPlayer while a file is playing, it will remember where it left off and will resume 
playing there when it is restarted. Note that if you’re playing audio, MMPlayer will 
keep playing it in the background. So if you want to use the resume function for an 
audio file, you need to pause playback before exiting MMPlayer. 

When MMPlayer resumes a file, the file will be paused, so you need to press the 
play button to start playing. 

6.3.2 Autoplay/Autoload 

MMPlayer can be made to automatically load, and even start playing, a playlist by 
saving a playlist called Autoload.m3u or Autoplay.m3u in the root of a memory 
card. 

When MMPlayer finds an Autoplay.m3u file, it will start playing it in fullscreen 
(provided the first file is a video file). 
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7 Playing mail attachments 
MMPlayer registers with the Exchange Manager in the Palm OS. Doing so enables 
other applications to use MMPlayer as an external viewer for the registered media 
types. The most common application that uses other applications as viewers are 
mail clients that wants to view mail attachments, but there could also be many 
other types of applications that can use viewer applications. 

The only thing you need to do is to start MMPlayer once. If it hasn’t yet registered 
with the Exchange Manager, it will do so. From then on, you will be able to use 
MMPlayer as a viewer application for your mail application. 

Note that all mail clients may not take advantage of viewer applications, but the 
Palm OS 5 standard mail application “VersaMail” does. 
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8 Streaming via HTTP 
MMPlayer can also play streaming media directly from a server on the internet.  To 
stream media, you first need to make sure your PalmOS device is connected to 
the internet. There are many possible ways this can be done.  Please refer to your 
PalmOS device manual for instructions on connecting to the internet. 

When your Palm has a usable network connection, you need to add a file with the 
prefix http://. This will indicate that the file should be fetched from the address 
specified. To do that, add a file as explained in 6.2.2 and then select HTTP in the 
top-right list. When HTTP is selected, a few extra buttons and a line will be 
displayed. The line is used to type the location of the file. 

 

 

 

8.1 http:// 

The http:// button simply adds that text to the line. Most URLs on the internet starts 
with http:// and the buttons simplifies entering that text. 

8.2 .com 

This button adds the text .com to the line. 
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8.3 List 

The List button lists the content of the directory written on the dotted line. This is 
very useful if you have lots of files on a file server and want to list the content and 
browse around as if it were a memory card. 

8.4 Mark 

The mark button adds the current URL to a list of bookmarks. These bookmarks 
can then be selected quickly using the top-left drop-down-list. 

At the bottom of the top-left drop-down-list there’s a selection called “Edit Marks...”. 
Select this to edit the list of HTTP bookmarks. 

8.5 .m3u 

MMPlayer can also read .m3u playlists. So if you have an .m3u playlist, simply 
select that file and all included files will be added to your current MMPlayer playlist. 
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9 Listening to Podcasts 
A podcast is actually not more than a mp3 file that can be streamed via HTTP. So, 
if you know the exact URL of a podcast, you can enter this URL and stream it via 
HTTP. But the podcast feature of MMPlayer makes it much easier by allowing you 
to enter the RSS feed of the podcast, which contains information about the 
podcasts broadcasted so far. 

A couple of such RSS feeds are already added to the list of podcast bookmarks. 

As with HTTP streaming, you first need to make sure your PalmOS device is 
connected to the internet. See the previous chapter for more info. 

When your Palm has a usable network connection, you need to add a podcast to 
the playlist. To do that, add a file as explained in 6.2.2 and then select Podcast in 
the top-right list. When Podcast is selected, a few extra buttons and a line will be 
displayed. See the previous chapter for more info about those buttons. 

 

 

 

The podcast bookmark list can be edited by selecting “Edit marks...” in the list. 



MMPlayer Manual Rev 2.0 22(57) 

10 Listening to Shoutcast radio 
A shoutcast radio station is simply radio on the internet. If you have a fast enough 
internet connection you can listen to shoutcast radio with MMPlayer. 

10.1 Launch MMPlayer from browser 

The easiest way to do it is to browse to a list of shoutcast radio stations (such as 
www.shoutcast.com) using the Palm browser and then click the button (Tune In! 
on the sample page) to start listening to the station, see the picture below. 

 

When you click the button (which is actually a link to a .pls file), the browser will 
ask you what to do with the file using the dialog below. It can also say “MMPlayer” 
or “Device” instead of “Drive”. If it only has an option to save the file to Card, you 
probably need to start/exit MMPlayer once to register the .pls file extension. The 
next time you click the .pls link it should add the extra option. Make sure the 
MMPlayer/Drive/Device button is selected and tap Yes to continue. 

http://www.shoutcast.com/
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Next, you are presented with an option to “Save” or “Save and open” the file. Tap 
“Save and open” to launch MMPlayer and start playing the file, see below. 

 

 

10.2 Enter HTTP link manually 

If you don’t have a browser on your device or if you for other reasons can’t use that 
way, you can enter the HTTP link to the shoutcast station manually instead. Please 
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see chapter 8 for info about how to do that. A shoutcast radio station can for 
example look like http://64.236.34.106:80/stream/1040 
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11 Hardware buttons 
Many controls and settings in MMPlayer are also accessible using the PalmOS 
hardware device buttons. This chapter describes the buttons as they appear on a 
Tungsten | T3. The buttons on your PalmOS device may be different.  However, all 
controls most likely will be available on your device also.  Explore your device. You 
should be able to find the right button.  

11.1 The D-pad 

The D-pad is used to control playback. Note that this type of navigation is disabled 
if the “Use D-pad navigation” is enabled in the GUI settings (see 12.4.5). The key 
mapping is pretty logical: 

Select: Play/pause 

Left: Seek backward in the current file 

Right: Seek forward in the current file 

Up: Increase volume 

Down: Decrease volume 

11.2 Hard buttons 

Most Palm handhelds have 4 hard buttons that are usually used to launch the 4 
PIM applications (Calendar, Contacts, Tasks and Memos). These 4 buttons can be 
used to control various settings of MMPlayer and are particularly useful when 
viewing a video in fullscreen (which means that no buttons are visible on the 
screen). 

To be able to use the hard buttons, make sure the “Use Buttons” checkbox is 
selected in the settings, see 12.1.5 for details. 

11.2.1 Zooming 

These two buttons are used to change the zoom mode. There are 6 zoom modes: 

1/2x zoom: Halves the video size, (320x320->160x160) 

1x zoom: No zoom applied 

2/3x zoom: Zooms by a factor of 3/2 (214x214->320x320) 

3/4x zoom: Zooms by a factor of 4/3 (240x240->320x320) 

2x zoom: Doubles the video size 

Best fit:  This mode selects the mode that best fills up available video area. 
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The Calendar buttons steps up in this list and the Contacts button steps down. 
This means that generally, Calendar zooms down and Contacts zooms up. 

 

Tech talk 

In most situations, the mode with no zoom applied (1x), would be the fastest of the 
available zoom modes. This is not the case in MMPlayer however. For various reasons, 
the zooming is applied by a function that needs to be executed for every frame. So, the 
limiting factor is actually the number of bytes that needs to be read from memory and then 
written to the screen buffer. Given this limiting factor, the fastest of the modes is actually 
the 2x zoom mode because that mode only reads ¼ as many bytes as the 1x mode. 

To summarize, if high frame rates are desired, you may decrease the video resolution 
when encoding the video and use a suitable zoom mode to increase it to fullscreen when 
playing. 

11.2.2 Rotation 

There are four rotation modes: 

• Follow GUI 

• No rotation 

• Rotation left 

• Rotation right 

The Tasks button toggles between these four rotation modes. Some Palms, 
notably those with a 480x320 screen, have a rotation setting in the status bar that 
is used to rotate the view, except the LifeDrive that has a rotation button on the 
side. If MMPlayer’s rotation mode is “Follow GUI”, it will follow the rotation of the 
currently selected OS rotation. If it is any other rotation mode, MMPlayer will not 
care about the OS setting. 

Note that MMPlayer’s rotation mode only affects how the video in the video area is 
rotated. It does not affect the rotation of the rest of the GUI. 
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Tech talk 

When viewing a landscape (widescreen) video on a Palm with a 320x480 screen, it’s often 
desirable to rotate the video (and the Palm) to make better use of available screen area. 
This rotation can be done either when encoding the video or by MMPlayer when playing 
the video. If MMPlayer is rotating, it will degrade performance somewhat, but not much. A 
penalty of about 4% can be expected but not more. 

If the rotation is done when encoding, it means that the video is explicitly encoded for 
viewing on a 320x480 device only. If played on any other device, it must be de-rotated by 
the player. Another, more subtle effect is that the rotation *may* make the video harder to 
decode and it may actually play slower than if the video wasn’t rotated at encoding time but 
rotated by MMPlayer at play time. 

Conclusion: Don’t pre-rotate unless you really need to and if you’re certain MMPlayer will 
actually perform better. 

11.2.3 OSD settings 

Besides being able to change zoom and rotation modes while playing, there are 
also a set of other settings that can be changed without leaving fullscreen mode. 
They are called On Screen Display or “OSD”. 

The following OSD settings are available: 

• Volume 

• Pan 

• Brightness 

• Contrast 

• A/V Sync 

• Video position 

The last of the hard button (Memos on some Palms) is used to browse through this 
list of OSD settings. When this button is pressed, the next settings name and 
current value is displayed for a second. Use the “up/down” buttons of the D-pad to 
change the setting. If the current OSD setting is “Video position”, the left/right 
buttons of the D-pad can also be used to move the video position left or right. 

The A/V sync settings can be used to compensate for bad audio/video 
synchronization. If you notice that the sound effect is generally heard before (or 
after) the corresponding video effect, you may use the A/V sync setting to 
compensate for this difference. 
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12 Settings 
This chapter describes the settings dialog, or rather dialogs since it’s divided into a 
set of sub dialogs. 

Enter the settings dialog by selecting the menu “File->Settings…”. 

  

At the top of the settings dialog, there’s a dropdown list with the six different sub 
dialogs. Select any of them to show the corresponding sub dialog. 

12.1 Video settings 

The video settings sub dialog lets you set various video related parameters. 

 



MMPlayer Manual Rev 2.0 29(57) 

12.1.1 Window zoom 

The window mode zoom factor is used when viewing video in a video area in a 
window. See 11.2.1 Zooming for more info about zoom modes. 

12.1.2 Fullscreen zoom 

The fullscreen zoom factor is used when viewing video in fullscreen mode. See 
11.2.1 Zooming for more info about zoom modes. 

12.1.3 Window Rotation 

Use the window rotation setting to select which rotation is used in window mode. 
See 11.2.2 Rotation for more info about rotation modes. 

12.1.4 Fullscreen Rotation 

Use the fullscreen rotation setting to select which rotation is used in fullscreen 
mode. See 11.2.2 Rotation for more info about rotation modes. 

12.1.5 Use buttons 

This checkbox must be checked to be able to use the hard buttons as described in 
11.2 Hard buttons. 

12.1.6 B-frame skip threshold 

The B-frame skip threshold setting is for advanced users and can be left at the 
default setting (250) for most situations. 

When MMPlayer is playing a video clip, the video may sometimes lag behind the 
audio causing the audio and video to get out of sync. When this happens, 
MMPlayer skips certain frames (B-frames) to be able to catch up with the audio. 
The B-frame skip threshold setting is used to decide when MMPlayer will start 
skipping B-frames. When the setting is set to 250, it will start skipping B-frames 
when the video is 250ms behind the audio. 

12.2 Audio settings 

The audio settings sub dialog lets you shut off audio if needed. 
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12.2.1 Play audio 

This box lets you control if audio should be played when playing a video. Under 
normal circumstances, the audio should be enabled, but some videos might have 
unsupported audio tracks. In those cases, try to shut off the audio and try playing 
the video again. 

12.2.2 Benchmark audio 

From MMPlayer version 0.2.12, the audio track is also played when playing in 
benchmark mode. But if you want to play the video as fast as possible without 
audio, uncheck this box. 

12.3 Buffer settings 

The buffer settings sub dialog contains settings for the audio and video buffers 
used when decoding audio and video. 
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12.3.1 Free memory display 

Above the audio buffer setting line, some information about available memory are 
displayed. In Palm OS, there are two distinct kinds of memory; storage memory 
and dynamic memory. 

Storage memory can be thought of as the hard disk of a computer. Programs and 
data can be stored there but to be able to process the data, it must be read from 
this area and stored in internal memory. 

Dynamic memory is like a computer’s internal RAM. Every program needs an area 
where temporary computations are made. In the case of MMPlayer, temporary 
computations means audio/video decoding, and this in turn means that lots of 
memory is needed -- much more than the average Palm OS program. If you have 
difficulties playing a file, it may be caused by too little free dynamic memory. The 
only way to fix this is to remove some programs or other data from your Palm. 

The available amount of memory is represented by two numbers. The first is the 
total number of kB available and the second is the largest available chunk (also in 
kB). So a reading of: 

14817/14814    416/241 

means that there are 14817 kB of storage memory available and the largest 
storage memory chunk is 14814 kB. There are also 416 kB of dynamic memory 
available and the largest dynamic chunk is 241 kB. 

The largest chunk is displayed to show the largest possible buffer size that can be 
set. The audio and video buffers use one chunk of storage memory each, so in the 
case above no buffer can be larger than 14814 kB. 
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12.3.2 Audio buffer 

The audio buffer is used to store undecoded audio data that has been read from 
the file, but has not yet been decoded. In some circumstances, this buffer needs to 
be increased from the default 64 kB. In particular, the buffer may need to be 
increased to 200-400kB when streaming over an internet connection. 

12.3.3 Video buffer 

The video buffer is used to store undecoded video data that has been read from 
the file, but has not yet been decoded. A large video buffer makes it possible to 
play a file that may otherwise be impossible to play. However, as the video buffer 
is filling up, it means that the video channel is lagging behind and this will probably 
be noticeable as a temporary unsynchronized audio and video. 

There are also some codecs, like mjpeg which is often used by small digi-cams, 
that sometimes needs a quite large video buffer, sometimes several MB. 

The default video buffer is 256kB. 

12.3.4 Show buffer indicators 

If this box is checked, three (or four) small dots will be visible while playing a video. 
The upper represents the audio buffer usage, the middle represents the video 
buffer usage and the lower represents the Frames Per Second (FPS) regulator. If 
streaming, there will be a fourth dot showing how fast the streaming connection is. 

Audio buffer usage indicator 

This indicator shows how much of the audio buffer is currently used. If the indicator 
is all the way to the left, it means that the audio buffer is empty resulting in a 
possible audio buffer underflow. This can cause the audio to stutter. If it’s all the 
way to the right, it means that the buffer is full and may cause dropped audio 
packets.  This may be heard as corrupted audio. 

Video buffer usage indicator 

This indicator shows how much of the video buffer is currently used. If the indicator 
is all the way to the left, it means that the video buffer is empty, (which is of no 
concern). If it’s all the way to the right, it means that the video buffer is full and may 
cause dropped video packets resulting in video artifacts. 

FPS regulator indicator 

The FPS regulator tries to keep the video in sync with the audio by regulating the 
FPS (Frames Per Second). If this indicator is in the middle, everything is fine. If it’s 
to the left of the middle, the video is slowing down to let the audio catch up and if 
it’s to the right of the middle, the video is speeding up to catch up with the audio. 
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Streaming speed indicator 

If streaming over the internet, this indicator shows how fast data is coming in from 
the server. It’s not possible to exactly see how fast the connection is, but if the 
audio and video buffer indicators are fairly still, it means that the connection is fast 
enough to play the file. 

12.4 GUI settings 

The GUI settings include some controls to affect the GUI. 

 

12.4.1 Halfsize 

If this is checked, a font that is half the size of the standard system font will be 
used. (A personal favorite is to check all three font checkboxes. It gives a good mix 
of readability and overview.) 

12.4.2 Large 

If this is checked, the large system font will be used. 

12.4.3 Bold 

If this is checked, the font will be bold. 

12.4.4 Playlist format 

This setting lets you select the format of the playlist. “Filename only” displays only 
the filename part of the file and “Full path” displays the full path to the file including 
the protocol name (ext:, int:, http: etc.). 
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12.4.5 Use D-pad navigation 

On some devices, typically Treo phones, most programs are possible to control 
completely with the 5-way D-pad for easy one-hand navigation. So, if this is 
checked, there will always be one control in focus. If the control in focus is a button, 
you can press the button with the D-pad center button, if the control in focus is a 
slider, you can grab the slider with D-pad center and then use the direction buttons 
to move the slider, etc. 

Note that when D-pad navigation is enabled, it also means that the old style 
navigation (as described in 11.1) is disabled. 

12.4.6 Screen blanking 

To conserve battery while playing music, you can activate the screen blanking 
feature by checking this box. When checked, a numeric field is displayed, letting 
you select the time before the screen is blanked. 

12.5 Performance warnings 

When MMPlayer detects that the file being played is too complex for the currently 
used device, it may display a performance warning with a hint to the user about 
how to make the file play better. The performance warning checkboxes can be 
used to prohibit certain warnings to be displayed, see below. 

 

Note that MMPlayer can usually diagnose why a file doesn’t play well. However, 
it’s not perfect. MMPlayer uses a couple of rules and makes a guess based on 
them. So do not take the warnings too literally. 
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12.5.1 Too small audio buffer 

This warning is given when the audio buffer is too small for the video being played. 
Increase the audio buffer and try again. 

12.5.2 Too small video buffer 

This warning is given when the video buffer is too small for the video being played. 
Increase the video buffer and try again. 

12.5.3 Too large video resolution 

This warning means that the video played has too large a video resolution to be 
played in real time on the currently used device. You need to either re-encode the 
video using a smaller video resolution or play it on a faster device. 

12.5.4 Too high audio interleave 

This warning means that the audio interleave used when encoding the video was 
set too high. This causes the video buffer to fill up and may also cause a little 
jumpy video. 

12.5.5 Too high video bitrate 

This means that the video bitrate used when encoding the video was set too high 
for the currently used device. You need to either re-encode the video using a lower 
video bitrate or play the video on a faster device. 

12.5.6 Non-standard audio frequencies 

(This warning is not used as of version 2.0. Instead, the non standard frequency is 
resampled to the nearest standard frequency.) 

When this is checked, MMPlayer will warn if you try to play a file with a non-
standard audio frequency. Normally, the PalmOS should warn if an unsupported 
audio frequency is used. However, some devices try to play any frequency which 
will (most often) result in a crash. 

If you experience instant crashes (fatal alert) when playing a certain file, try to 
enable this warning (if it was disabled) and play the file again. It will probably warn 
about a non-standard audio frequency and you can play the video without audio. 

12.6 Streaming settings 

When MMPlayer is streaming files from the internet, it preloads a certain amount of 
data before playing. You can set how much data to preload with the streaming 
settings. 
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12.6.1 Preload at start 

This setting decides how much data to preload before starting to play a file. The 
setting is presented in percent of the buffer size (see 12.3). So if the buffer size is 
set to 1000kB and this setting is set to 10, 100kB will be preloaded before 
MMPlayer starts to play the file. The first buffer to fill up enough will trigger 
MMPlayer to start playing. 

12.6.2 Preload at underrun 

If MMPlayer cannot fill the buffers at the rate they’re being used up, i.e. if the total 
bitrate of the file is larger than the internet connection bandwidth, then the buffers 
will eventually become empty. This setting is used to set how much data to preload 
when that happens. 
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13 Skins 
Skins are alternative looks that can be changed by the user. Several skins are 
shipped with the MMPlayer distribution. Additional skins can be found on 
http://mmplayer.com/skins.php 

13.1 Changing skin 

To change the current skin, select the File->Skin menu. 

  

Then select the new skin from the list of installed skins and tap Ok. After a few 
seconds, the new skin should be visible. 

If the skin you want to use is installed on a memory card, select the memory card 
where it’s installed using the upper right dropdown list and then browse to the skin 
file using the file selector. 

After activating a new skin, try collapsing/expanding the virtual grafitti area and 
also try different rotation settings to see how the skin changes to take advantage of 
the different size constraints. 

13.2 Installing skins 

Skins come in two file formats. Either as a Palm database, i.e. a PDB file, or as a 
XML file. Usually, a skin should be distributed in both these formats to give the 
user more flexibility. 

If the skin you want to install is a PDB file, just install it as usual using Hotsync. 
Such skins will be visible in the internal memory section of the skin selection dialog, 
i.e. you don’t have to select the memory card to see it. 

If the skin you want to install is a XML file, you need to install it on a memory card 
before use. If you use the standard installation application, the file will probably be 
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installed in the /PALM/Launcher directory of the card. This means you need to 
browse to that location when you’re about to select the skin for use in MMPlayer. 

13.3 Creating skins 

To create a new skin, you basically just need a paint program you’re comfortable 
with. It helps if the paint program has support for layers; this makes the process of 
moving buttons and other controls around much easier. 

When you’re done painting your new skin, you need to save every button, control 
and other piece of graphics as gif or jpg files and then you need to use a special 
tool to collect all these files into one XML file. Last, you need to write the 
specifications for each form that the skin should have. 

This process is described further in the skin developer SDK that can be 
downloaded from http://mmplayer.com/skins.php. It’s not very complicated and if 
you need help, don’t hesitate to drop us a mail at support@mmplayer.com and we 
will assist you in your efforts. 

http://mmplayer.com/skins.php
mailto:support@mmplayer.com
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14 Statistics 
MMPlayer collects various statistics while playing. These statistics can be used to 
see how hard the file was to play and if it needs to be encoded at lower settings. 

When a file has been played, or when it has been paused, the statistics values can 
be viewed by selecting the File->Statistics menu. 

 

The following form is then displayed: 

 

Tot time 

Displays the total time the file has been played. 
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Dec/Skipped frames 

Displays the number of decoded and skipped frames. MMPlayer may skip some 
frames when playing a video if the CPU is too slow to display all frames.  

Thrown pkts vid/aud 

Displays the number of thrown video and audio packets. Packets may get thrown 
away if the corresponding buffer is full when the packet is read. If this value is non 
zero, then the buffer should be increased, at least when playing the current file. 

Max pkts vid/aud 

Displays the max number of video and audio packets in the buffer. If the max 
number of video packets is large, it means that this video was hard to decode and 
the video track was lagging behind some of the time. 

Max usage vid/aud 

Displays the max number of used kilobytes of the video and audio buffers. These 
values can be used to estimate how to set the video and audio buffer sizes. 

Aud buf underruns 

Displays the number of audio buffer underruns. An audio buffer underrun is a bad 
thing and means that the audio stuttered during play. (The example above had 131 
audio buffer underruns and needs to be encoded with much lower settings to play 
well.) 

Idle (ticks) 

Displays the number of idle ticks during play. This is a coarse value indicating how 
much free time the CPU had when playing the file. 

Dynamic mem headroom 

Displays the amount of free dynamic memory while playing the file. If the number 
is positive, enough dynamic memory was available to play the file at maximum 
performance. But if the number is negative, it means that so called storage 
memory had to be used, resulting in a somewhat slower playback. Note that the 
video track will advance at the normal speed, but it will probably skip more frames 
if enough dynamic memory wasn’t available. 
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15 Benchmark mode 
The benchmark mode can be used to see how fast MMPlayer can play a video on 
the current device. This is useful if you want to maximize playback quality while still 
being able to play it on your device. 

The benchmark mode is started by selecting the File->Benchmark menu. 

 

The currently selected video will start playing as fast as possible. This process 
cannot be interrupted, so do not start a benchmark for a very long video, unless 
you are prepared to wait. The playback is done in fullscreen mode and the 
currently set rotation and zoom modes are used when playing. 

You can use the “Benchmark audio” setting in the audio settings dialog, (see 
12.2.2), to select whether the file should be played with or without audio. If playing 
with audio, all audio packets will be decoded. However, if the video can be played 
faster than real-time, some audio will be skipped, but if the video is played slower 
than real-time, the audio will sometimes get silent resulting in audible clicks. 

If the file is played without audio, the audio packets are still read from the file but 
not decoded. 

Doing the benchmark with audio is of course more accurate and will result in a 
better measurment of the device since both video and audio decoding are tested. 
The benchmark mode without audio is mostly useful when comparing against older 
MMPlayer versions that can only play benchmarks without audio. 

When finished playing the file, statistics values are displayed. 
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These values are not the same as described in the statistics chapter. In the picture 
above, some of the values are 0, but when doing a real benchmark, most should 
have real values. Also note that the time for Pack read, Audio decode, Video 
decode and Image convert are not measured in any specific unit, but rather shows 
how long time the different stages take in comparison to the other. The main 
purpose of these timers are to assist the developer when optimizing decoding, they 
are generally not useful for the end user. 

Tot time 

The time it took to play the video. 

Decoded frames 

The number of decoded frames during play. Note that in benchmark mode, no 
frames are skipped. Frames are skipped during normal play to keep the video in 
sync with the audio, but since there’s no audio track playing in benchmark mode, 
there no need to skip frames. 

Skipped frames 

Should always be 0 after a benchmark run. 

Pack read 

The time it took to read the data from the source, memory card, internal memory or 
internet.  

Audio decode 

The time it took to decode the audio data.  
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Video decode 

The time it took to decode the video data.  

Image convert 

The time it took to convert the decoded video frames to the display.  

Dynamic mem headroom 

Displays the amount of free dynamic memory while playing the file. See chapter 14 
Statistics for more info. 

FPS 

Frames Per Second for the video just played. This is the most important value on 
this form and shows how fast the video can be played on this particular device. 
Note that since the video is played without audio in benchmark mode, it will play a 
bit slower when played with audio. Exactly how much slower depends on the audio 
encoding settings. 

15.1 Benchmark all 

The “Benchmark all” function can be used to run a benchmark for all files in the 
playlist. The result of each file will not be displayed in a statistics form like the other 
benchmark function, but will be written to a file on a memory card. The file is called 
MMPlayerStats.txt and contains the statistics values for all files played. 

An error dialog will be displayed if MMPlayer is unable to write the file to the 
memory card. This may, for example, happen if there’s no card inserted. 

Note that devices with a built in “memory card” such as the LifeDrive and Tungsten 
T5 will probably write this file to that device instead of any card inserted in the SD 
slot. 
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16 Playlists 
MMPlayer can save playlists as m3u files. M3u files are a very simple file format 
and only contains a list of file names. To handle playlists, use one of the playlist 
functions in the File menu, see below. 

If no playlist have been loaded or saved, MMPlayer saves the current playlist in 
internal memory. But when a playlist has been named, either by loading it or by 
saving it, this name is used instead of the default. 

 

16.1 Load playlist 

This function opens a file selection dialog and lets you select a playlist to load. 

16.2 Save playlist 

Saves the current playlist. If the current playlist doesn’t have a name, a file 
selection dialog is opened and lets you enter a name for the playlist. 

16.3 Save playlist as 

Saves the current playlist using a new name. A file selection dialog is opened and 
lets you enter a name for the playlist. 

16.4 Clear playlist 

Removes all files from the playlist and clears the playlist name. I.e. the default 
playlist stored in internal memory will be used from now on, or until you give the 
playlist a name using any of the save functions above. 
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17 Bookmarks 
Bookmarks can be used to mark chapters or other places you want to be able to 
skip to in a video. 

17.1 Setting a bookmark 

When playing a video, pause it and select the Bookmarks->Mark here menu. 

 

A bookmark will be added at this point and you will later be able to skip to it. 

17.2 Editing bookmarks 

If you need to edit the bookmarks after setting them, you may open the bookmark 
editing form by selecting the Bookmarks->Edit menu. 

 

The following form is displayed: 
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This form can be used to delete bookmarks, change the time of a bookmark and 
change the name of a bookmark. 

 

Tech talk 

Bookmarks are stored in files that are named as the video file but with the 
extension .bkm. The syntax of those .bkm files are not documented here but they are 
very easily edited by hand if needed. 
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18 Registration 
An unregistered copy of MMPlayer will display a text asking you to register after 
about 1 minute of playing a file. It will also start to decrease the volume (and 
contrast if playing video).  

If you decide to register MMPlayer, please revisit the site where you downloaded 
MMPlayer and buy a license. The registration process is now optimized and most 
buyers are able to unlock MMPlayer within 5-10 minutes. 

There are now three ways to unlock MMPlayer: 

1. Download a key from the Help->Register dialog within MMPlayer over the 
internet. 

2. Enter a 25 character code in the Help->Register dialog manually. 

3. Download a key file and install it in internal memory. MMPlayer will read 
this file and enter the 25 character code. 

Note that some software stores will not support some of these methods. 

18.1 Downloading a registration key 

After purchasing MMPlayer, you can download a key file from 
http://mmplayer.com/register. You will first need to select which version of 
MMPlayer you want a key for. The next page contains all necessary info but the 
only thing you need to do is to enter your email address and Hotsync ID, then 
press “Get key”. This will generate a key that will unlock your copy of MMPlayer. 
Download the key and install it internal memory to unlock MMPlayer. 

18.2 Online activation 

If your device has an internet connection, you can use the built-in activation 
function which will download a key and install it automatically. Start MMPlayer and 
select the Help->Register menu to see the Registration form. Then tap the “Reg 
online…” button. 

When prompted, please enter your email address. This must be the same email 
address you used for the MMPlayer purchase. As explained above, the notification 
of your purchase may not reach us immediately, so if your email address isn’t 
recognized, please wait 30 minutes and try again. If it still doesn’t work, contact us 
on support@mmplayer.com and we’ll check what went wrong. 

Also, if you get an error message after tapping Get Key, please try once or twice 
more before giving up. 

http://mmplayer.com/register
mailto:support@mmplayer.com
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18.3 Register using a code 

You can also unlock MMPlayer by entering the 25 character code manually. This 
code is, by some software stores, presented to you when you buy MMPlayer. Just 
enter the code to unlock MMPlayer. Note that this code is generated using your 
Hotsync ID and will only unlock MMPlayer as long as the Hotsync ID stays the 
same. It also means that you must enter the correct Hotsync ID on your account at 
the software store, otherwise the code will not work. 

Note that some characters can be easily mixed up, for example O (upper case o) 
and 0 (zero) or l (lower case L) and 1 (one). To make it easier to tell such 
characters apart, you should copy and paste them into a word processor (or 
notepad) and view them using a really large font, see below. 

O 0 l 1 
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19 Getting media to (and from) your Palm 
MMPlayer can play media either from internal memory or from an external memory 
card. The easiest way is to install the files to an external memory card to avoid 
unnecessary conversions. But for users without memory card, the internal option is 
available. 

19.1 Internal memory 

To install media to internal memory, the media file must first be converted to a 
PDB file. You can do this by downloading the par utility from this location: 

http://www.djw.org/product/palm/par/

Par is a DOS command line program and you must consequently open a DOS 
window in order to use it. To convert a media file to a PDB file, type the following 
command: (with par in the path) 

par c -a stream song.pdb "name of the song.mp3" MMPA MMPL song.mp3 

 
(If your media file is some other type than mp3, then you should of course use that 
file extension instead of mp3 in the command line above. The file extension is 
important, because MMPlayer sometimes need it to determine the format of the 
file.) 

Once the PDB is made, install it to the Palm using the Palm Desktop installation 
program. MMPlayer will then be able to use the PDB file as a media source.  

To add that file to the playlist, select “internal” in the file selection dialog and then 
select the file from the list, (the file should show up as “name of the song.mp3” if 
the above example was used to convert the file.) 

19.2 Memory card 

There are quite a few ways to transfer a media file to a memory card, here's some: 

• Use a card reader. This is actually the only long-term solution. They are not 
expensive. Transferring a 100 – 200MB movie with a card reader takes less 
than 2-3 minutes.  Contrast this with the 20-60 minutes required by using the 
standard install method. 

• Use Card Export II from Softick. It can be used to view the memory card 
(inserted in your PalmOS device) as a disk under Windows. 

• Use Pilot Install. Pilot install is free for non-commercial use and lets you install 
files to your Palm's memory or to the memory card without having to complete 
the whole hotsync procedure. 

• Use the standard Palm Desktop install tool. Start the install tool and drop the 
files you want to install in its window. Different types of files will be copied to 

http://www.djw.org/product/palm/par/
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different directories on the card depending on the current file type mapping of 
the PalmOS device. Some programs change this mapping to make certain file 
types end up in certain directories. As a general rule of thumb, audio files are 
copied into /AUDIO and images and videos are copied into /DCIM. Some 
programs (such as Kinoma producer) integrate with the standard install tool 
and try to convert certain file types instead of simply installing them. This will 
cause the file to be unusable to MMPlayer. The standard Install tool can also 
be really slow and error prone for large files. I would suggest one of the other 
alternatives. 

• Newer Palm devices such as the Tungsten | T5 and the LifeDrive often have a 
built-in way to transfer files to and from the device. This can be almost as fast 
as a card reader. 

19.3 Removing media 

MMPlayer doesn’t manage files, it’s a media player. Think of it as a media player 
on a computer. Such media players can’t remove files, you need to use the 
explorer or a similar program to do that. The scenario is similar on a Palm with 
MMPlayer, except there’s no standard file manager in PalmOS. However, there 
are plenty of 3rd party file managers for PalmOS, both free and commercial. Some 
of them are listed below. Of course, if you have a card reader or Card Export, you 
can remove media files from memory card like any other file. 

FileZ is a free alternative.  It is a full featured file management utility. It can be 
downloaded from http://nosleep.net 

McFile costs $10-15.  It can do all the things FileZ can. It can also act as a simple 
backup program and beam files directly to and from memory cards. 
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20 Encoding videos 
In theory, MMPlayer should be able to play any DivX (or mpeg) movie you care to 
throw at it. The problem is that most DivX movies are made for viewing on a much 
larger screen than the 320x320 or 320x480 screens of current Palm devices. And 
even if MMPlayer was able to scale the video size to the 320x320 area, it would 
still lack the CPU power to decode large video sizes. To be able to play videos 
smoothly with MMPlayer, you must therefore either:  

• Find the video you want to view in a suitable size. 

• Re-encode the video to a suitable size. 

The latter option may seem daunting for the beginner, but it's actually not that hard. 
Once you get the hang of the different processes involved, it's mostly just fun. And 
if you get uncertain about what's the "best" setting along the way, you just need to 
try one setting now and then try another later. You will need to encode some 5-10 
videos before you get a feeling for how different settings affect the end result. 
Here's a little guide on how to encode videos using VirtualDub (a free tool). 

20.1 Software 

First, you should download and install the software you need: 

1. VirtualDub (http://www.virtualdub.org). This is a freeware program that lets 
you encode a video (and audio) into the .avi format using any codec you 
have installed. 

2. DivX codec (http://www.divx.com). The DivX codec is used to encode the 
video stream of the .avi file. 

3. MP3 codec (Visit http://www.afterdawn.com/software and search for “Lame”) 
The Lame mp3 codec is used to encode the audio stream of the .avi file. 

20.2 Encoding 

When you have installed all the software listed above, start VirtualDub and load 
your video file you wish to convert with File->Open video file; where File->Open 
means click the File menu and under the File menu select Open. 

20.2.1 Video 

Then you must tell VirtualDub how to encode the video: 

4. Select Video->Full processing mode 

5. Select Video->Filters... This opens up the filter dialog where you can add all 
sorts of filters to be applied to the video before encoding. We want to resize 
the video so press Add... and select the resize filter. Enter the desired size 
and optionally a filter mode and press Ok. (Different filter modes results in 

http://www.afterdawn.com/software
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different grades of smoothness of the resized picture. Just try them and see 
which one you prefer). If you want to cut the left and right borders to convert 
the movie from widescreen, you can select Cropping... and use the cropping 
dialog to crop the input video. 

6. Select Video->Frame Rate... MMPlayer may skip frames in order to keep up 
with the audio stream if the video size is too large. On a slower device, 
MMPlayer generally does not skip frames at 160x160, but it skips B-frames 
for larger video sizes. So, when you encode a video, you can either encode 
the video using B-frames or you may set the frame rate by yourself using this 
dialog. If you choose to change the frame rate, the best way to do it is to use 
the Frame rate decimation (decimate by 2) because this doesn't affect 
audio/video synchronization. We recommend using B-frames instead of 
changing the frame rate.  This option will let you play the video on more 
powerful devices without skipping. 

7. Select Video->Compression to select the video codec. All codecs installed 
will be listed here. Select the DivX codec and press Configure. The DivX 
codec dialog has quite a few settings and I won't explain them all, just the 
most important ones. 

• Bitrate mode: Quality based - it tries to enforce a constant quality 
throughout the video, 1-pass - it limits the bitrate at a specified value, 2-
pass (or multipass) - it uses several passes to distribute high bitrates to 
fast moving sections and lower bitrates to slower moving sections. 
Multipass encoding requires more than one Save (see below). The first 
save is done using 1st pass, consecutive saves are done using 2nd pass 
(or nth pass). 

• Encoding bitrate: Sets the bitrate, if the bitrate mode is bitrate based. 

• Quantizer: Sets the quality, if the bitrate mode is quality based. 

• Use Bidirectional encoding (Profiles tab): This enables B-frames. You 
must at least select the Portable profile to be able to check this box. This 
setting is only available in DivX Pro.  

20.2.2 Audio 

Now it's time to configure the audio stream: 

1. Select Audio->Full processing mode 

2. Select Audio->Interleaving. In this dialog, the most important thing is to keep 
the interleave low, otherwise MMPlayer might have to throw away video 
packets when playing. (You will notice this as choppy blocks, i.e. artifacts, 
when playing). Set the audio interleave to 1 frame. 

3. Select Audio->Compression.  This is the audio version of the codec selection 
dialog and lists all codecs currently installed. Select MP3 (or MPEG Layer-3) 
and select a suitable format in the list to the right. Don't overdo it. A very high 
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audio bitrate will take too much CPU to decode and may degrade 
performance notably. I have good results with ~16-22kHz mono and bitrates 
around 16-32 kBit/s. It's also important to choose a frequency that the target 
device can play. For example, the T|T can't play 24kHz audio, but most other 
common frequencies, see 4) 

4. If you need to change the audio frequency, this can be done using the Audio-
>Conversion dialog. It's straight-forward. Just select what you want and 
press Ok.  

20.2.3 Do it 

Not it's time to encode the AVI file. If you want to make short sample, you can 
select Video->Select Range and set the length of the video. Then select File-
>Save as AVI.  Set a file name and press Ok. 

20.3 Alternative software 

There are of course other ways to encode videos, here’s a few pointers. 

20.3.1 Dr. DivX 

If you think all this sounds too complicated, there are solutions for the really green 
beginner. One of them is called Dr. DivX (http://www.divx.com/divx/drdivx/) and is 
very easy to use. The downside is that you can't do everything you can do with 
VirtualDub. Be aware of that if you plan to buy it, you pay for ease-of-use, not 
powerful functions. 

20.3.2 JobMaker 

Another good alternative for beginners is the MMPlayerJobMaker tool 
(http://www.mmplayerjobmaker.tk/). It's a tool made by an MMPlayer user that can 
be used to make scripts for VirtualDub. The JobMaker does away with many of the 
tedious and hard-to-master setting jungle of VirtualDub. 

20.3.3 Pocket DVD Studio 

Pocket DVD Studio is a one-click encoding solution to convert your DVDs to AVI 
files suitable for MMPlayer. 

20.3.4 PocketDivXEncoder 

PocketDivXEncoder is a free program (GPL licence) to encode videos for PDAs 
and is a good alternative to use when encoding videos for MMPlayer. It can't do 
DVD ripping though, only the conversion step. So it's optimal if you have a large 
video that you want to re-encode for MMPlayer. See http://divx.ppccool.com/ for 
more info. 

http://www.divx.com/divx/drdivx/
http://divx.ppccool.com/
http://divx.ppccool.com/
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20.4 Additional info 

If you have more questions about encoding videos for MMPlayer, please visit the 
encoding section of the MMPlayer forum pages (http://mmplayer.com/forums/). 
There, you will find other users who had similar problems you’re having, and you’ll 
probably also find a few solutions. 

http://mmplayer.com/forums/


MMPlayer Manual Rev 2.0 55(57) 

21 Troubleshooting guide 

21.1 Playing 

Symptom Cause Solution

The audio and video are 
not synchronized. 

MMPlayer sometimes 
fails to keep audio and 
video in sync. 

Compensate using the A/V Sync OSD 
setting, see 11.2.3 OSD settings. 

The audio volume is very 
low. 

The amp slider has been 
decreased. 

Increase the amp slider. (Note that some 
skins don’t have an amp slider. You may 
have to change to the default skin to see it.) 

The hard buttons don’t 
work 

The “Use buttons” 
checkbox in not checked.

Check the “Use buttons” checkbox on the 
video settings form. 

MMPlayer crashes 
frequently. 

Some users have 
problems with MMPlayer 
when some hacks are 
installed with TealMaster.

Disable all hacks, or one at a time, and try 
again. 

MMPlayer crashes when 
playing a certain file. 

Some files need a larger 
video (or audio) buffer. 

Increase the video (or audio) buffer and try 
again. If it still crashes when the buffers are 
several MB each, feel free to send a short 
clip to support@mmplayer.com and we’ll try 
to see what’s wrong. 

MMPlayer displays a 
fatal alert 
“DmWriteCheck failed”. 

MMPlayer failed to 
allocate sufficient 
memory to play the file. 

Free some memory by removing some 
applications or data from internal memory 

When I press “Add” in 
the playlist, there’s no 
files to select. 

MMPlayer doesn’t list all 
files on the card but only 
those in the current 
directory.  

Browse to the correct directory to see the 
files you have installed on the card. The file 
selection dialog behaves just like a file 
selection dialog on a computer. 

When I press “Add” in 
the playlist, I only see 
audio files, no video files. 

The standard Palm 
Install tool usually installs 
audio and video files in 
different directories. 
Audio files goes to 
/AUDIO and 
video/picture files goes to 
/DCIM. 

See 19.2 for more info. 

There’s no way to 
browse to any other 
directory than the default 
/AUDIO 

You’re probably using 
the very old version 
0.1.0. This version is 
audio only and doesn’t 
allow browsing. 

Upgrade to the latest version. 

I *am* using the latest 
version of MMPlayer and 
I still can’t browse to 
another directory. 

Perhaps you need to use 
another font? If you use 
the half-size font but not 
bold nor large, it’s quite 
small and you might not 

Change to a bigger font, see 12.4 GUI 
settings. 

mailto:support@mmplayer.com
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see the two dots 
representing the parent 
directory. 

When I use the slider to 
move to a certain 
position in a clip, it just 
starts over from the 
beginning. 

MMPlayer uses the index 
at the end of AVI files 
when seeking. If 
MMPlayer fails to read 
that index, seeking is not 
possible. 

Use a program called DivFix to rebuild the 
index. See http://divfix.maxeline.com/. 
Pocket DVD Studio sometimes write the 
index incorrectly, but this has been fixed in 
the latest release. 

I tried rebuilding the 
index as described 
above but seeking is still 
not possible. 

Long videos have a large 
index requiring much 
memory. MMPlayer 
might run out of memory 
while reading the index 
causing seeking to be 
disabled. 

Free some memory or split the movie into 
smaller parts. 

I have lots of memory 
available but seeking still 
doesn’t work. 

MMPlayer may run out of 
audio buffer while 
seeking for the next 
keyframe. 

Increase the audio buffer. See 12.3 Buffer 
settings. 

    

21.2 Registration 

Symptom Cause Solution

My MMPlayer is suddenly 
unregistered again. 

You have changed 
Hotsync ID. Your key will 
only unlock MMPlayer for 
your original Hotsync ID. 

Contact support@mmplayer.com and 

describe why you need a new key. 

I have paid for MMPlayer. 
When will the key arrive? 

We don’t send the key via 
mail, but you should 
always get a mail 
describing how to 
proceed. 

See chapter 18 Registration for more info. 

I have paid for MMPlayer 
but the notification mail 
hasn’t arrived. 

Some users, most 
commonly Hotmail users, 
have their spam settings 
too tight which causes our 
notification mail to be 
discarded.  

Try to download a key anyway. Chances are 
your purchase info have reached us so you 
can get a key. See chapter 18 Registration
for more info. 

When I press “Get key” on 
the register page, I get an 
error saying something 
about unrecognized file 
type. 

Some browsers, Netscape 
7.0 is one of them, doesn’t 
handle php correctly. 

Try another browser, like Mozilla or Internet 
Explorer. You may also try to save the php 
file to disk, and then remove the .php suffix
so that the file is called “MMPlayerKey.pdb”. 
Then you can double-click on the key and 
install it. 

When I try to download a This can have two Double-check that you used the same mail 

http://divfix.maxeline.com/
mailto:support@mmplayer.com
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key, I get a message that 
my mail address isn’t 
recognized. 

causes. Either, you have 
entered a different mail 
address than the one you 
used for the purchase or 
your purchase notification 
hasn’t reached us yet. 

address you used when registering. I.e. 
check your account at PalmGear, 
Handango, PayPal etc. 

 


	1  Introduction
	2 Installation
	2.1 Required files
	2.2 Optional files
	2.2.1 MIDI
	2.2.2 Skins

	2.3 Upgrading from a previous version

	3 Quick start
	4 Compatibility
	4.1 Device specific setup
	4.1.1 Palm Tungsten | T3
	4.1.2 Handspring Treo 600 and Zire 31
	4.1.3 Sony Clie (TG/NX/NZ)


	5 Playable media types
	5.1 Formats, Codecs, and Protocols
	5.2 File formats
	5.3 Codecs
	5.4  Protocols

	6 MMPlayer controls
	6.1 The main form
	6.1.1 Play button
	6.1.2 Stop button
	6.1.3 Back button
	6.1.4 Next button
	6.1.5 Volume slider
	6.1.6 Pan slider
	6.1.7 Brightness slider
	6.1.8 Contrast slider
	6.1.9 Repeat button
	6.1.10 Shuffle button
	6.1.11 Position slider
	6.1.12 Eq button
	6.1.13 Eq band sliders
	6.1.14 Amp slider
	6.1.15 Fullscreen toggle

	6.2 The playlist form
	6.2.1 Play button
	6.2.2 Add button
	6.2.3 Remove button
	6.2.4 Move up button
	6.2.5 Move down button

	6.3 Other features
	6.3.1 Resume
	6.3.2 Autoplay/Autoload


	7 Playing mail attachments
	8 Streaming via HTTP
	8.1 http://
	8.2 .com
	8.3 List
	8.4 Mark
	8.5 .m3u

	9 Listening to Podcasts
	10 Listening to Shoutcast radio
	10.1 Launch MMPlayer from browser
	10.2 Enter HTTP link manually

	11 Hardware buttons
	11.1 The D-pad
	11.2 Hard buttons
	11.2.1 Zooming
	11.2.2 Rotation
	11.2.3 OSD settings


	12 Settings
	12.1 Video settings
	12.1.1 Window zoom
	12.1.2 Fullscreen zoom
	12.1.3 Window Rotation
	12.1.4 Fullscreen Rotation
	12.1.5 Use buttons
	12.1.6 B-frame skip threshold

	12.2 Audio settings
	12.2.1 Play audio
	12.2.2 Benchmark audio

	12.3 Buffer settings
	12.3.1 Free memory display
	12.3.2 Audio buffer
	12.3.3 Video buffer
	12.3.4 Show buffer indicators
	Audio buffer usage indicator
	Video buffer usage indicator
	FPS regulator indicator
	Streaming speed indicator


	12.4 GUI settings
	12.4.1 Halfsize
	12.4.2 Large
	12.4.3 Bold
	12.4.4 Playlist format
	12.4.5 Use D-pad navigation
	12.4.6 Screen blanking

	12.5 Performance warnings
	12.5.1 Too small audio buffer
	12.5.2 Too small video buffer
	12.5.3 Too large video resolution
	12.5.4 Too high audio interleave
	12.5.5 Too high video bitrate
	12.5.6 Non-standard audio frequencies

	12.6 Streaming settings
	12.6.1 Preload at start
	12.6.2 Preload at underrun


	13 Skins
	13.1 Changing skin
	13.2 Installing skins
	13.3 Creating skins

	14 Statistics
	Tot time
	Dec/Skipped frames
	Thrown pkts vid/aud
	Max pkts vid/aud
	Max usage vid/aud
	Aud buf underruns
	Idle (ticks)
	Dynamic mem headroom

	15 Benchmark mode
	Tot time
	Decoded frames
	Skipped frames
	Pack read
	Audio decode
	Video decode
	Image convert
	Dynamic mem headroom
	FPS
	15.1 Benchmark all

	16 Playlists
	16.1 Load playlist
	16.2 Save playlist
	16.3 Save playlist as
	16.4 Clear playlist

	17 Bookmarks
	17.1 Setting a bookmark
	17.2 Editing bookmarks

	18 Registration
	18.1 Downloading a registration key
	18.2 Online activation
	18.3 Register using a code

	19 Getting media to (and from) your Palm
	19.1 Internal memory
	19.2 Memory card
	19.3 Removing media

	20 Encoding videos
	20.1 Software
	20.2 Encoding
	20.2.1 Video
	20.2.2 Audio
	20.2.3 Do it

	20.3 Alternative software
	20.3.1 Dr. DivX
	20.3.2 JobMaker
	20.3.3 Pocket DVD Studio
	20.3.4 PocketDivXEncoder

	20.4 Additional info

	21 Troubleshooting guide
	21.1 Playing
	21.2 Registration


